View Full Version : Wip3out ePSXe Online Multiplayer

6th February 2011, 07:44 AM
anybody want to play me?

here is the concept

Splitscreen Internet wipeout 3 SE PAL using ePSXe v1.5.2 and a P2P netplay over the tunngle network.

it worked just grand for me, and with sound
also I found the Mupen64k emulator and Wipeout64 works very well using the
same method.

anyway if you would like to try to beat me at either LOL
i can assist some peeps getting going
start by downloading tunngle and installing it, creating a account and then adding me "negitivenrg" to there friends list. n we will go from there

6th February 2011, 01:07 PM
Interesting concept.
This might be just what Jabberjaw has been waiting for.
And I wouldn't be surprised if Darkdrium777 got in on this either, if only to test out how it plays.
It will be interesting to see the results.

6th February 2011, 02:56 PM
I would love to play(and try splitscreen),but I don't have the 3SE image. The last WipEout I played was Wip3out. And the main emu I use is pSX. If you want me to change emulators,I can though.

6th February 2011, 04:52 PM
awesome spread the word :D
I will make a video to upload once i get some peers going!

to awnser F.E.I.S.A.R's question only ePSXe supports netplay, so PSXv1.13 cant be used atm.

6th February 2011, 05:04 PM
Actually, I tried playing V8 2nd Offense PS1 with a friend over a VPN but never managed to actually get it to work.
I then tried the N64 version with a ROM (I know, bad bad bad) but that didn't work either.
Kaillera is some BS IMO (If you've actually managed to get it to work congrats, please post a tutorial.)

6th February 2011, 06:24 PM
no luck eh? well dont feel bad i didnt just stummble into the solution, i have multiple cpu's for testing and it took dozens of tries to find a plugin config that jived.
i belive that other games will work in just the same way, but i know sound sync is an issue in both n64 and ps1 netplay plugins. it did not to seem to be an issue on the psx version of wip3out (worked with sound). i will have to confirm but i think wo64 has to run with no sound to be stable.

6th February 2011, 06:29 PM
A quick NegitiveNRG's ePSXe netplay Tunngle guide...

working games? many, but im only concerned with wipeout v3.o PAL PSX


-know how to download and install programs
-know how to unzip/manage files
-know how go give a *.exe administrative privlidges in vista/7
-a playstation ISO or Disc
-a playstation bios
-have winrar installed ( http://www.rarlabs.com )
-good network connection

I used my windows 7 hp pavilion laptop
Im sure other windows operating systems will run the same

1> Go to http://www.tunngle.net and register a account
2> Download & Install Tunngle

Remeber to check tunngle is accepting connections
(Tunngle -> System -> Options -> Test)
and if you use a internet router Tunngle requires you to forward opened ports..

next you need is the playstation emulator

I decided to use ePSXe v1.5.2 for compatibility reasons

you can get the emulator and plugins here (custom package)


once downloaded ,extract the files somewhere you will be able to locate them.
( i used my "personal" folder located at C:\User\USERNAME\Emulators to avoid permission issues in win7)

next part is to run ePSXe and configure it

open epsxe.exe then click config then Wizard Guide
this configuration should be matched for proper netplay

BIOS= scph1001 - USA
VIDEO= Pete's D3D Drive 1.77
Sound= ePSXe SPU core 1.5.2
Cdrom= ePSXe CDR WNT/W2K core 1.5.2
controller= your on your own to configure your input device
then ok to complete

Now Back to ePSXe go to config and now netplay
and select PS4NET neta 0.4 from the drop downlist
then hit okay

restart ePSXe to make sure you changes are final

now to connect to another pc, this is where tunngle comes in
boot it, sign in, and join a channel
(you should see your virtual IP adress in the bottom
left of tunngle once you have joined a channel )

in ePSXe go File -> run ISO (or CD) and browse for your game
killera P2P tool should automaticly launch
(the emulator will crash if netplay plugin is enabled and you try to run the game without netplay tool)

your now ready to connect and play splitscreen

-im a wipeout fan not a programer xD
-i have poor grammer and spelling
-not all pc's /isp's are created equal
-the configuration on the server and clent side should be identical for sync reasons

-if you made it this far in the guide you should be able to chat with me (or the peer your trying connecting to)
directly in tunngle, and connecting should be straight forward at this point

6th February 2011, 08:28 PM
Whaaat this works!?!?! I don't have a PAL copy of W3O, just W3O SE...I'll be trying this as soon as I have the time (and don't have a migraine :lol). This is so exciting! Even though I don't need one on one to get whipped, the game itself does that nicely! Anybody else get it going yet other than NegativeNRG?

6th February 2011, 09:01 PM
yeah it works!
actualy im using wipeout 3 SE PAL version
and im just sitting around waiting for some competitors to eliminate
so I uploaded me running a single player timed run with ePSXe as soon as i get someone eles playing I will upload a VS netplay video


6th February 2011, 11:00 PM
I'd quite like to be involved in this. I have W3O and 2097 but haven't played them much because there's not much of a social element to it. Playing online would probably help motivate me.

It would be nice to get it working with NeGcon so that I could have more of that experience too.

I will have a crack at getting it working some time in the week. Good work -NegativeNRG.

7th February 2011, 03:06 AM
glad to help, i hope i was clear enough. the NeGcon looks hardcore! but i think my heart still belongs to my logitech dual analog wireles rummble pad xD

heres a list of the wo games im playing (i have regular wo3 SaturnReturn)

my netplay images/roms
wipeout3 - NTSC - SLUS 008.65
wipeout3 SE - PAL - SCES 028.45

my non netplay ones
PS1 - Wipeout - NTSC - SCUS 943.01
PS1 - Wipeout XL - NTSC - SCUS 943.51
PS2 - Wipeout Fusion - NSTC
PS2 - Wipeout Fusion - PAL
PC - WO2097D3D

Btw, there is a pcsx2 eathernet plugin under develpoment. I havent found any kaillera/cyberpad plugins yet but when i do im sure i will post

7th February 2011, 03:17 AM
No harm in trying I suppose but would work best with closer clients I assume
Can't help but feel that lag would be a significant issue, especially across the pond? Nevertheless, downloading now, already have tunngle

7th February 2011, 03:29 AM
excelent! add negitivenrg to your friends list*

yea lag could be a problem, but there is only one way to find out ;) i just need someone across the pond to play

7th February 2011, 03:57 AM
Which room are you in? I'm not sure how to use the friends list

7th February 2011, 04:11 AM
Misc --> Game Emulators

7th February 2011, 05:06 AM
well conncting over the pond failed our austraila-canada game had too much lag
ships loose control :S

Thanks for your help rdmx.

__________________________________________________ _________

well im going to keep looking for a way to make this work, but on the positive side myself and rdmx had a go at trying a few different emu's and configs and rained sucsess with Mupen64v0.79 with no sound.

here is the vid

kind of amazing when you consider the geographical distance ;)
fraps also ruined the nice framerate i had on the emu, but i think rdmx has a nicer vid
if anyone still wants to test wo3 with me just let me know.

__________________________________________________ _____

The new emulator im using. it boasts better netplay.


filetered graphics are so much nicer
wip3out SE SCES 028.45 - haulted for me when loading memory cards when game started.
wip3out SLUS 008.65 - worked very well and am waiting to test netplay

7th February 2011, 10:00 PM
@NegativeNRG - please use the edit button for your updates, rather than making consecutive posts in the same thread within a short time.


7th February 2011, 10:18 PM
So, to be sure: this works for both if the game has a splitscreen mode and if the game allows system-link? Or just system-link?

EDIT: Meh, this emulator stops playing the game (Vigilante 8) on a whim with no error of any kind, it just closes the screen. Forget it.

8th February 2011, 09:32 AM
I'm still trying to get the right plugin that works very well...for me.

8th February 2011, 04:49 PM
ePSXe 1.5.2 -> Config
video= Pete's D3D Driver 1.77 is for older cards
P.E.Op.S. OpenGL Driver 1.78 runs very nice on new cards
hit configure then in the bottom left corner corner you will see "fast and "nice"
hit fast. then change it to render in Window mode 640*480
check the box marked use FPS limit then hit ok. (find the resolution for you when it runs smooth)
sound= ePSXe SPU core 1.5.2 enable sound, enable cdda checkmarked.

start with peops opengl, if that doesnt emulate correct go for pete's
;D hope it helps. whats your cpu/vid card look like?

9th February 2011, 01:30 PM
I used to play Wipeout 2097 and 3SE on ePSXe on Linux platform with an old relic computer so it should be ok.
But I'm afraid I can't play fake-link with the Linux version (too bad this emulator is not maintained or open source :'( )

11th February 2011, 07:47 PM
I'm going to try this.

12th February 2011, 05:39 PM
find me in the wipeout xl channel in tunngle for help testing or a match ^^