Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Steam Early Access update 20160819

  1. #1
    Join Date
    Dec 2015
    Timezone
    GMT -8
    Posts
    58

    Default Steam Early Access update 20160819

    hi all

    Weve been working very hard since our 20160725 build and are pleased to announce that as of Friday 0003h GMT youll be seeing an update which has numerous improvements, additions, changes and fixes:

    - destruction sequence improvements - WIP
    - multiplayer - lobby auto-refreshes - in-lobby text chat - player tag occlusion - optimisation - WIP
    - aesthetic tweaks / changes to Trans Atol
    - aesthetic tweaks / changes to Niagara
    - aesthetic tweaks / changes to Mannahatta
    - new pickup health and weapon icons - WIP
    - SFX tweaks - still WIP
    - multiple bug fixes
    - weapons system tweaks and additions - WIP
    - introduction of KERS system (see below) - WIP

    WEAPONS: pick primary and secondary weapons in garage - pickup energy charges to fire with Right or Left shoulder buttons
    KERS v1.0 - KINETIC ENERGY RECOVERY SYSTEM - WIP:
    - (see blue bar at base of HUD) deploy KERS by holding Left and Right upper shoulder buttons together for a temporary speed boost.
    - collect KERS Crystals during a race - harvest Crystals from destroyed craft - WIP
    - KERS rewards perfect piloting; collisions reduce and achieving the perfect line accelerates collection of Crystals

    More news to follow shortly re the re-opening of the TPP.

  2. #2
    Join Date
    Oct 2006
    Location
    Sydney Australia
    Timezone
    GMT + 10
    PSN ID
    blackwiggle
    Posts
    3,863

    Default

    I've just been having a quick test of the new build.

    KERS doesn't seem to be working, I've tried numerous times.
    When I look in options > Controls, the top shoulder buttons aren't listed, maybe that has something to do with it, as if nothing is mapped to those controls, then any input from them will be ignored ?
    I've tried holding down both shoulder buttons for differing amounts of time hoping that might trigger the speed boost, 99% of the time nothing happens, it 'Might' of happened once on Manahatta, but the delay from button pressing to when the speed boost occurred was several seconds, and caused my ultimate destruction, I'm still not sure what happened on that race..... EDIT - after several more races, for some reason I seem to inexplicably explode in a ball of flames for no apparent reason, it's not from other craft collision, or running into mines.... it's as if my shield has suddenly died... very strange.

    On a positive note, I like how you have brighten things up on Trans Atol with the yellow on some of the overhead girders, and side banking, still in two minds about what seems to me to be a added amount of opacity [dustiness sort of look -reminds me of Temptesh Bay from Fusion]

    I also like that you have brightened up the tunnel sections of Niagara, that was sorely needed, and you managed to do it just subtly enough that you can now see where you are going a lot better than before, without losing the cavernous feeling of that part of the track.

    The raised speed pads were a bit of a shock when I first saw them, they look quite high when in cockpit view, but not so much that they are a distraction.....speaking about speed pads, looks like you have moved some [removed] or altered the configuration somewhat on Niagara and Trans Atol, looks like I'm having to learn them again.
    Hopefully I can try Online this weekend

    Some small requests for the next build.
    1] A countdown start - the current one is similar to waiting for traffic lights to change - I also find the Green start/finish sign uninspiring
    2] Ability to lock players race view in options, I have to change it manually each race and after being re-spawned.
    Last edited by blackwiggle; 19th August 2016 at 06:19 AM.

  3. #3
    Join Date
    Dec 2015
    Timezone
    GMT -8
    Posts
    58

    Default

    hi BW

    Quote Originally Posted by blackwiggle View Post
    I've just been having a quick test of the new build.

    KERS doesn't seem to be working, I've tried numerous times.
    When I look in options > Controls, the top shoulder buttons aren't listed, maybe that has something to do with it, as if nothing is mapped to those controls, then any input from them will be ignored ?
    I've tried holding down both shoulder buttons for differing amounts of time hoping that might trigger the speed boost, 99% of the time nothing happens, it 'Might' of happened once on Manahatta, but the delay from button pressing to when the speed boost occurred was several seconds, and caused my ultimate destruction, I'm still not sure what happened on that race..... EDIT - after several more races, for some reason I seem to inexplicably explode in a ball of flames for no apparent reason, it's not from other craft collision, or running into mines.... it's as if my shield has suddenly died... very strange.
    interesting - Im away at Gamesom right now so I cant confirm mapping and spontaneous combustion issues on Steam - Ill ask the studio to have a look and see if they can replicate

    the current plan is that KERS should only be activated when its at 100% - right now you seem to be able to use it almost anywhere on the gauge

    the delay you mention is a balancing issue and were keen to hear what people think about it - turbo lag right now?

    Plans for KERS are to move to being able to finish a race and convert to Tech Credits within the garage. Alternatively, when racing with your team mate (2 person team) with pilot to pilot VOIP, donate or transfer KERS to them if they need a speed boost or shield power-up.

    Its clearly a new dynamic which hopefully introduces a whole new set of interesting challenges to competitive teams.
    Quote Originally Posted by blackwiggle View Post

    On a positive note, I like how you have brighten things up on Trans Atol with the yellow on some of the overhead girders, and side banking, still in two minds about what seems to me to be a added amount of opacity [dustiness sort of look -reminds me of Temptesh Bay from Fusion]

    I also like that you have brightened up the tunnel sections of Niagara, that was sorely needed, and you managed to do it just subtly enough that you can now see where you are going a lot better than before, without losing the cavernous feeling of that part of the track.

    The raised speed pads were a bit of a shock when I first saw them, they look quite high when in cockpit view, but not so much that they are a distraction.....speaking about speed pads, looks like you have moved some [removed] or altered the configuration somewhat on Niagara and Trans Atol, looks like I'm having to learn them again.
    Hopefully I can try Online this weekend

    Some small requests for the next build.
    1] A countdown start - the current one is similar to waiting for traffic lights to change - I also find the Green start/finish sign uninspiring
    2] Ability to lock players race view in options, I have to change it manually each race and after being re-spawned.
    [/QUOTE]

    Countdown start is being worked on
    Camera choice is a fix in progress - it pisses me off too ;-)

  4. #4
    Join Date
    Oct 2006
    Location
    Sydney Australia
    Timezone
    GMT + 10
    PSN ID
    blackwiggle
    Posts
    3,863

    Default

    Since finding people I consider worthy of the test codes to be given out, since I had little feedback in my neck of the woods [most are PSN members-not Steam].... I thought , fair enough, let's gain interest where it counts.

    I couldn't help myself, I had to PSM Infoxicated and give him a code.
    Even though he says his laptop is 5 years old, I think somehow, somewhere, he will test this build..... as I said to him, No BR's No BS, FF is like the Wipeout of old as a racer

  5. #5
    Join Date
    Dec 2015
    Timezone
    GMT -8
    Posts
    58

    Default

    thanks for that

    Quote Originally Posted by blackwiggle View Post
    Since finding people I consider worthy of the test codes to be given out, since I had little feedback in my neck of the woods [most are PSN members-not Steam].... I thought , fair enough, let's gain interest where it counts.

    I couldn't help myself, I had to PSM Infoxicated and give him a code.
    Even though he says his laptop is 5 years old, I think somehow, somewhere, he will test this build..... as I said to him, No BR's No BS, FF is like the Wipeout of old as a racer
    - - - Updated - - -

    hi BW

    we're looking into the KERS depleting shield and sudden death - not able to repeat yet

    if you've remapped, one thing you could try is resetting the key mapping to default - my bad with button naming - the buttons to press are the LB and RB / both Bumpers together

    we will be looking into the turbo lag thing

    Quote Originally Posted by blackwiggle View Post
    I've just been having a quick test of the new build.

    KERS doesn't seem to be working, I've tried numerous times.
    When I look in options > Controls, the top shoulder buttons aren't listed, maybe that has something to do with it, as if nothing is mapped to those controls, then any input from them will be ignored ?
    I've tried holding down both shoulder buttons for differing amounts of time hoping that might trigger the speed boost, 99% of the time nothing happens, it 'Might' of happened once on Manahatta, but the delay from button pressing to when the speed boost occurred was several seconds, and caused my ultimate destruction, I'm still not sure what happened on that race..... EDIT - after several more races, for some reason I seem to inexplicably explode in a ball of flames for no apparent reason, it's not from other craft collision, or running into mines.... it's as if my shield has suddenly died... very strange.

  6. #6
    Join Date
    Oct 2006
    Location
    Sydney Australia
    Timezone
    GMT + 10
    PSN ID
    blackwiggle
    Posts
    3,863

    Default

    When I originally started the download of the new build, I ticked the option [Start once downloaded]

    I did this and nothing in OPTIONS showed the shoulder buttons that would allow K E R's to work.

    After a further shutdown and restart of the gaming PC, when going into options, the shoulder buttons now appear in Options, but, sadly, the trigger mechanism to get KER's operative, still isn't working .... well not working as I suspect was the design.

    Got me stumped ???

  7. #7
    Join Date
    Dec 2015
    Timezone
    GMT -8
    Posts
    58

    Default

    hi BW

    just checking to see if you can activate KERS

    we're having quite a discussion on activation - personally I like the 2 button hit but there are some design issues with this for remapping

    Quote Originally Posted by blackwiggle View Post
    When I originally started the download of the new build, I ticked the option [Start once downloaded]

    I did this and nothing in OPTIONS showed the shoulder buttons that would allow K E R's to work.

    After a further shutdown and restart of the gaming PC, when going into options, the shoulder buttons now appear in Options, but, sadly, the trigger mechanism to get KER's operative, still isn't working .... well not working as I suspect was the design.

    Got me stumped ???

  8. #8
    Join Date
    Oct 2006
    Location
    Sydney Australia
    Timezone
    GMT + 10
    PSN ID
    blackwiggle
    Posts
    3,863

    Default

    I've waited till I've had all three different bars of the HUD full, then tried to use KERS.
    Result was some weird, I was going to say acceleration - but it wasn't, it was more a Warp to a different part of the track, BUT the thing is, activation of dual shoulder triggers used up any weapon I had, pluse any shield I had.

    It seemed like I was transported forward down the track, and then shot with my own weapon,....result with shield also depleted, due to this one, dual trigger pressing action, was I went down in a ball of Flames.
    Hence my original post on 'Spontaneous Combustion' syndrome

  9. #9
    Join Date
    Dec 2015
    Timezone
    GMT -8
    Posts
    58

    Default

    yes - it's all placeholder stuff at the moment - wip - interesting that it warps you to another part of the track - i haven't been able to repeat that

    Quote Originally Posted by blackwiggle View Post
    I've waited till I've had all three different bars of the HUD full, then tried to use KERS.
    Result was some weird, I was going to say acceleration - but it wasn't, it was more a Warp to a different part of the track, BUT the thing is, activation of dual shoulder triggers used up any weapon I had, pluse any shield I had.

    It seemed like I was transported forward down the track, and then shot with my own weapon,....result with shield also depleted, due to this one, dual trigger pressing action, was I went down in a ball of Flames.
    Hence my original post on 'Spontaneous Combustion' syndrome

  10. #10
    Join Date
    Oct 2006
    Location
    Sydney Australia
    Timezone
    GMT + 10
    PSN ID
    blackwiggle
    Posts
    3,863

    Default

    Maybe it was a combination of the weapon I had in play [that pulse one that surrounds your craft in Blue when triggered], the KERS actually working and whatever effect you have programed to show when that happens, combined with the speed I was traveling at the time, combined with yet again the self destruction effect [the camera POV change when that happens]....with all this happening simultaneously, it seems like a warp effect as my track vision, apart from the extreme sides of the screen, was pretty well none existent for a second or two

    I'll try it again later with a different weapon equipped and see what the effect is.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •