PDA

View Full Version : original WipEout on ePSXe - settings?



Neo-phyte A10
28th May 2003, 04:54 AM
I did a search of the boards and although there was a topic about this same problem, it was never actually answered, so I'm posting this in the hopes that someone has since discovered a solution. I am no stranger to using ePSXe - however, no matter what settings I use with the original Wipeout game, it slows down at times. I can run XL and W3 just fine, full framerates - it's only the first game that gives problems. Has anyone else discovered which settings will run the game best? I'm using Pete's OpenGL plug-in 1.70 and the Eternal SPU 1.40 on a 2Ghz/256RDRAM/64MB GeForce machine. I really -don't- think it's my system. ;) Some quirk in the game's programming I guess. Oh, and also, how the heck do I get the music to come through - all I'm getting is sound effects (this goes for all three games). Thanks ~

A10

the surgeon
21st September 2003, 10:55 PM
if you tell me how you got wipeout3 running i will tell you how to get the original wipe out to work :lol: get me on msm surgeon27@hotmail.com

Mano
21st September 2003, 11:09 PM
Its a known bug on emulation, thats why it doesnt work at correct speed, youre right, its not your system thats giving you the problem.

I would like to hear surgeonīs fix though, even if you dont point us the fix surgeon i may be able to help you with your wo3 problem, just post what happens qith the emu when you try to load the game so i can help you.

the surgeon
22nd September 2003, 05:26 PM
ok peeps these are the settings i use to get wipeout(original)to work
video driver=Pete's DX6 D3D Driver 1.74
sound=Null2's Audio Driver 1.4 (best sound driver imo)
cdrom=ePSXe CDR WNT/W2K core 1.5.2.

on the video setting tab i check the USE FPS LIMIT and set the frame rate to 60fps
i run this at 32 bit 1152x864 with texture sharpening on and antistropic filtering on
and thats it lads hope it works for you :D let me know how you get on :wink:

ps i run winxp by the way

lifekid42
22nd November 2003, 04:34 AM
Neo-phyte: regarding the music, there is a workaround that will benefit you in other ways as well.

You can get better performance in emulation if you rip the game to your hard drive and run it as an ISO instead. This will free up your cd-rom drive, so you can use it to play the soundtrack at the same time while you are playing the game. As an added bonus, the music never stops playing even in between races.

I recommend using Mooby's disk image driver. But remember to still choose the "Run CDROM" option in ePSXe, not the "Run ISO" option. That's because Mooby's plugin is still technically treated as a normal CDR plugin.

This method works particularly well with Wipeout, because the data track is very small. In other words, you don't need to include all those music tracks when you create your ISO image. If you use CDRWIN, you can get a visual representation of all the tracks on the disc, and it will let you choose to only copy the data track. The data track is only between 50 and 80 mb depending on which Wipeout game you're playing.

So you get faster game performance, you get the music to work, and the music will be continuous between races....... it's a win-win-win situation. :)

It won't help you with Wipeout 1 though. I'm having the same problem that you are. It has nothing to do with your system, (unless the surgeon is right about WinXP which i have yet to try). The game is just quirky and the emulator is having some kind of internal problem with it.

Also one more thing i would like to ask. Have any of you tried emulating multiplayer Wipeout with FPSe? As far as i know, FPSe is the only psx emulator that supports the parallel port, which is required for multiplayer in wipeout 1 and 2. The popular Cyberpad plugin will not help you with these games because it only supports multiplayer split screen. Of course i could always try Cyberpad with Wipeout 3, but my friend and i are bent on matching up in XL. SO i want to know if it's possible.

Lumpster
22nd September 2004, 10:30 PM
CD music:

ePSXe doesn't get the music from the playstation CD digitally (like windows media player does).
The Playstation gets it's CD music from the actual CD drive, all CD ROM drives have a built in CD player chip.
You need to connect the audio out pins on your CD ROM drive to the auxiliary input of your soundcard, then adjust the volume using your soundcard's mixer application.

Astral_Nomad
27th May 2006, 02:32 PM
Its a known bug on emulation, thats why it doesnt work at correct speed, youre right, its not your system thats giving you the problem.

actually, i figgered it out (for wipeout 1 / psx)... its not the emulator at all... works just beautiful for me. if you are using daemon tools (im using v3.44), turn on Analog Audio in options and it should work fine.. if that doesnt work, heres a step by step.

set up an aspi layer:
Windows xp doesnt come with one so you might want to go to adaptec and download one. im using the 4.71 version.. they say its buggy but ive had no problems.

to rip a proper wipeout iso 1:1 iso:
Nero Burning ROM SE v6.6.0.8
-Set your recorder to Image Recorder.
-Insert your CD into your drive.
-using "CD Copy"
under the tabs:
-copy options, choose the drive your disc is in. set read speed to 1x. Uncheck "on the fly". Will take longer to rip but will be less error-prone.
-read options, select "user define" in the drop box, check everything.
Click the Copy button, choose where to put the image and make yourself an iso.

setting up the virtual drive:
Daemon Tools v3.44
- got it from Zophar's Domain .. its old... i *think* its the pre-spyware version.. still works like a charm. Install it with defaults for the moment, and reboot when prompted for the virtual driver to load.

to set up epsxe:
these are what i deem the plugins with the most effect on the game.. tinker elsewhere as you wish.
-video - P.E.Op.S Soft driver 1.16 (I limited to 60 fps but its not mandatory)
-sound - Eternal SPU 1.41 (sound, cdda, xa all checked)
-cdrom - epse cdr wnt/w2k core (default, set to your virtual drive letter)

Now...
In daemon tools, right click on the tray icon
- go to Emulation, select All options on.
- go to Options, check Analog Audio.
- go to Virtual CD/DVD-ROM, to the drive listed, and select Mount Image.

Select your wipeout image, start epsxe, click on Run CD-ROM and you are off to the races so to speak. Im running an 800mhz AMD on win xp and 320mb ram and as i said.. runs beautiful.

Party hard. :rock :rock :rock

Mano
28th May 2006, 06:09 AM
I have been using a virtual drive, but never thought of using it to try WO1 through epsxe, i mostly used it so i dont need to put the cd everytime i want to run a game that i play often.

What you explain makes sense, setting it to analog audio might free something in the emulation to run correctly, will definitely try it. Thanks for the tip!

Viva thread reviving!

Astral_Nomad
31st May 2006, 12:52 AM
yeah.. i found that the games usually have the sfx hard coded into the software and then leave the music audio laid down as tracks on the disc in a different track mode like a mixed-mode cd.. thats why in some games you hear gun blasts or cars revving or whatever in some games but then background music is mysteriously absent...

that trick should work for most games having that issue because epsxe by default doesnt read those tracks due to choice of the developers not caring to expand development on the cd player portion of the BIOS, but daemon tools does if you turn that option on.

i understand the logic behind what the team for epsxe was doing when they said that they werent going to develop the cd player portion of the BIOS (because if you want to listen to music, you have a cd player in windows) but i think thats why there were still emulation issues.. maybe the cd player in the psx BIOS was more hooked into the game software than they realized?