PDA

View Full Version : Some issues with Wipeout2097 on PC



Recluse
29th June 2011, 12:31 PM
Hi everyone. Total Wipeout n00b here.

I got Wipeout HD on the PS3 as part of the Welcome Back program, mainly for my son..but of course, I got hooked. Since he gets most of the PS3 time and I am pretty much a PC gamer, I got hold of the Wipeout2097 D3D for Windows.

It runs well on my WinXP system with the slowdown patch.

I noticed a few oddities that maybe someone can help with.

When selecting keyboard + joystick (my preferred controller), the THRUST is always 100% and always maxes out automatically on start without me having to push any buttons. This is fine for the Novice Vector tracks, as I don't need to slow down anyway, and I quickly got Golds with and without Weapons activated. Moving up to the Venom circuit (Valparaiso, etc). I am crashing into the walls all the time, and I feel like if I could control Thrust and slow down into the turns, things would be better.

I've tried several things:


Setting all joystick button controls to NONE to use KB Thrust
Programming my stick to give Digital signals rather than DX programmed buttons


No matter what, whenever Keyboard + joystick is selected I have no control of Thrust, and also no Turbo boost at the beginning as Thrust starts automatically at the GO.

Also, a little bug... it seems that when I EXIT WO2097, my sound volume goes to zero. It still works in the game, but in Windows, I always have to open the Volume control and increase the WAVE SOUND slider from zero.

Thanks in advance for your assistance.

Flint Fandango
29th June 2011, 08:45 PM
I also have 2097 for PC (Win XP), and youīre right about the volume thing! Everytime I exit the game, the sound is completely turned off. Sorry to say that, but I still donīt have a clue why...
Iīve decided to take the path of least resistance, put a shortcut of the soundmanager on my desktop and changed the name into "restore sound after WO". ;)
I use a joypad to control my ship in 2097, so I canīt give you a hint concerning these other problems. Sorry.
But relating to the sound bug, youīre not alone! :D
(It wonīt solve the problem, but maybe itīs an easement!?)

Recluse
29th June 2011, 09:38 PM
Yes indeed! Thank you for confirming the sound issue. At least I know that my installation appears 'typical'. I suspected that most users on this forum 'gravitate' to joypads rather than conventional Flight Sim type sticks, so no worries on that other issue. Somewhere in the Big Wide Wipeout world there must be someone else who has seen it (and maybe fixed it....).

Flint Fandango
30th June 2011, 06:35 PM
Excellent!
I trust that thereīs someone in this forum who could have fixed it somehow;
this would be desirable, because I could also benefit from this knowledge.

Who might be our saviour?

JABBERJAW
1st July 2011, 01:32 PM
I have used controllers that do this as well, not sure why, maybe analog buttons cause it

Flint Fandango
1st July 2011, 03:39 PM
Thank you Jabberjaw, this is an interesting fact.
Iīve never tried to use another controller, therefore I couldnīt recognize the difference.

Recluse
24th July 2011, 01:31 AM
OK... given the large number of responses to the other issues, I am not going to get my hopes up now....:P

But....


All of a sudden, I get terrible graphics corruption on entereing the came after the splash screen and movies. Looks like kaleidescope lines radiating everywhere. Can not even see the menus.. trial and error even to QUIT. All I can think of is I did recently update my NVIDIA drivers (GTX260) to the latest version. BUT since even the old drivers are SO FAR Ahead of anything this game was made for, I am surprised it made a difference.
I use the Slowdown patch which includes the NO CD, but I also wanted to try the Network Patch and 1024x768 res for maybe someday, Multiplayer. I mount the CD ISO from DAEMON tools, but the game never recognizes it. I tried Drive E and K. D: is one of my hard drives so not available. I also tried putting the CD in one of my Physical CD drives with the same issues. I suspect the game wants it in D: and D: only. Any way to edit config files to make the game look at a particular CDROM drive?

EDIT: I think this is solved. I found an appropriate Registry Key that seemed to do the trick, but due to the graphics corruption, I can't really test.



Thanks in advance to all you Wipeout PC users.

Darkdrium777
21st December 2011, 08:07 PM
For the maxed thrust issue immediately on start, it's because for some reason it uses invert Z axis on the joystick. Put your throttle control on the joystick at maximum, and it will make the thrust in-game go down to 0. Also you might think to use it since it's an analog control, but for some reason (probably the same it uses invert Z) the throttle on my joystick is either full on or full off. I have to use the keyboard to accelerate.
As for your other issue with patching, I'm sorry I've done this a very long while ago and can't remember. :(

Recluse
21st December 2011, 11:15 PM
@Darkdrium:
Thanks!! If I can ever get around the graphics corruption issue I will try the throttle trick!

miljoneir
24th December 2011, 03:12 PM
i have a nvidia 6200 video card and i can confirm that the latest drivers are causing the graphic corruption. i didn't play the game for a while and suddenly it did not work anymore. the problem is that i did multiple driver updates so i don't know which one caused the bug. the only way i found out to solve it was by installing the drivers back from my cd.
hope that helps!

Recluse
24th December 2011, 05:30 PM
Thanks for confirming that! I was in the same boat. Couldn't remember which upgrades I had done. In the meanwhile, I'm sure I installed a game or two that will need the latest drivers. I am hoping (without much real confidence) that, at some point, a later NVidia driver will fix the issue that was created. This has happened a time or two before with other games, but Wipeout is so old that it may really require a driver rollback.

Recluse
28th January 2015, 02:57 AM
Thread resurrection in case it helps someone!

I got rid of the vertex spike graphic anomalies by dropping the contents of this file into the main Wipeout folder. Fixed some DirectDraw render issue!!

http://www.speedyshare.com/j5aCd/ddraw.zip

(Running on Windows XP)