View Full Version : Khara Descent + Quake = WTF?

5th December 2005, 07:56 PM
Sorry to copy the thread title, but it works.

When I try to use a Quake on Khara Descent it makes the noise and does nothing. This has happened EVERY time I tried to use it. Even when the computer uses it: I hear "Quake" but can continue racing with the confidence that I won't be hit by anything. Granted I haven't tried just sitting on a weapon pad and firing to see if it would happen again, but I've never had a Quake totally fail like it does. So I say, WTF?!

I have the US version. I tried searching for it on the forums and nothing came up. Someone please tell me they've seen this problem!

5th December 2005, 08:39 PM
Me to Megatron, don't remember if it was on Khara Descent or not, but have had quake fail on me a number of times :(

6th December 2005, 05:11 AM
I've had it happen intermittently on other tracks, but the one time I used it on khara descent I put it's failure down to my smacking nose first into a wall as I fired it

6th December 2005, 11:34 AM
I've had a few fail on me on various tracks, but only when I fire one just before or during a jump

6th December 2005, 12:56 PM
I think it may have to do with your nose being pitched too far down, as I've had rockets fail me the same way on occasion, though certainly not as often as quakes. When that happens, I chalk that up to picking up a dud, as would often happen with the nuke bombs in "Total Carnage"

I always think of the "WAP WAP WAAA-AAAAAP" sound that the dud nuke in TC makes when you pick one up.

6th December 2005, 02:23 PM
I've had two quakes misfire on me at Khara (I think they work at Koltiwa though), and I've had one "quake" warning with no red glow of death, a 100% misfire rate so far. I'm confident that it's a bug in the track, because I've fired quakes in much more adverse situations, with abnormal altitudes and pitches. Also, when a quake is supposed to misfire (over a gap in the track), it doesn't make the sound, so something's got to be wrong.

6th December 2005, 03:34 PM
the weirdest weapon bug I`ve seen was on Xlink. I was playing some guys on Alpha tour and on the first two races every weapon pad turned off just before I went over it, except on Vineta K where I picked up one weapon only, on lap one. On Modesto I was rejected every time. I was in the lead both races so it couldn`t have been a ship infront switching off the pad, and it was for the entire race. I never saw it happen again.

I`ve seen the quake misfire, but it seems to be very rare away from Khara descent.

6th December 2005, 04:51 PM
Well it's a relief to know that other people are having the same problem, but it confirms a bug on the track. Think we could see a SL download pack update?

6th December 2005, 05:21 PM
The early release of the Japanese Delta 2 had this problem as well, but it was fixed very quickly. In fact, the US pack seems to be suffering from the same problems as the Japanese one did as it seems the artwork problem with the Delta Tournaments is also present. I'm really surprised these bugs weren't nipped in the bud this time round.

Dogg Thang
8th December 2005, 07:50 PM
Yep, it's absolutely bizarre that these bugs were present and fixed so long ago and yet still made it into this release. A little shoddy but I would imagine it was a simple lack of communication between regional departments. SL would only fix what they were given to fix and these packs were probably delivered a long time ago and sat waiting to be released.

6th May 2006, 05:27 PM
im on Khara as i type this... i just now used a quake and it worked fine.

i am on the euro version... i never had quake fail on me.

sounds to me like the US version sucks greatly

6th May 2006, 08:11 PM
Hey, at least it won't be hitting you in the air when you are way above the track.

7th May 2006, 04:19 AM
I know Luckily it is on vector for me because I spend a lot of time on vector not when I need it most it could happen on any class :brickwall

7th May 2006, 10:40 AM
I've had tonnes of Quakes fail on Khara Descent. In fact, out of about 15, only one has ever worked (on the US version). It was when I was in the air, on the multiple jump fork at the start. It's failed everywhere else on the track :(.

And I thought the lack of artwork under the Delta golds was because they'd finally run out of images...