View Full Version : Firestar track hack on WipEout PC

25th September 2015, 09:25 PM

I'm excited to see the recent progress people have achieved in contributing to Dominic Szablewski's advances in reverse engineering the original Wipeout games. If only I was able to grasp the amazing programming knowledge and skills required I would create a track editor and help to re-create the original game in c/++. (I've been programming in c/++ as a hobby for a long time now but i'm still only an amateur!)

Anyhow, all this has inspired me to do a mild "hack" if you could call it that. Its surely been done before but I can't find talk of it anywhere online. .. But here it is.

You will need a cracked copy of the original Wipeout. I used the "Wipeout CD (1995)(Psygnosis).zip" Hoson/Replicator crack about 15MB which has no music and no sounds.

Copy the track data from TRACK14 folder into a temporary folder, there is a couple of readable text files, you will know if this is the firestar track data folder as it will contain the words "MARSY" .. look for other cues, its a interesting read, looks like compiler output for the developers circa 1995.

Copy the track data from TRACK02 folder into the TRACK14 folder and from the temporary folder into TRACK02. Basically its just a swap.

Run the game, go through the single race, select team etc and then select ALTIMA track. Firestar should load up instead. However many of the textures are corrupt/flipped and in the wrong place. But it is playable. For 19 years I wanted to play firestar on the pc but i could never get there until two nights ago :hyper

I haven't tried swapping other folders yet but this might have some further hacking potential, especially if someone could figure out how to correct the textures etc hmm.. custom track editor now anyone?

Note: I ran it on my old retro gaming windows 98 pc, DOSBOX didnt seem to work. It also crashes if there is any kind of CD in the drive. Cracked version doesnt seems to work in windows either.


Wipeout 2097 PC (Boxed)
Wipeout XL PC Disc
Wipeout 3d Rage ATI edition Disc
Wipeout PC x 2 (Boxed)

26th September 2015, 07:29 PM

I'm the author of WXX-Rebirth if you haven't seen it already:

(Firestar :D)


It is only the beginning as you can see above but Unity is quite helpful in that matter.

Regarding your test on DOS version, I guess there must be hard-coded stuff in the executable, because things works OOB in the WebGL experiment as well as on my project.

There are numerous things that are missing/incoherent from game data:

- such as textures on Firestar track edges are correct on the final game but not in the WebGL experiment
- starting blocks, I couldn't find any clue beside manually mapping each track
- etc ...

i.e. they did in the code.

To run it in Dosbox (Windows),
- install D-Fend Reloaded
- create a new profile : Complex games with 3d graphics (Profile menu)
- setup/edit the profile, disable GUS, set CPU to Max

the game will run properly with sound

Find the mappings between tracks and TRACKXX folders here:



Just did a simple test which ended up pretty interesting, on the DOS demo you can entirely delete the WIPEOUT folder and the demo will still run and load the track -> there is definitely lot more happening in the EXE than sole game logic. i.e. couple of track data is within the EXE.

Regarding modding/editing you will have to consider the following:
- texture in TIMs/CMPs should be correct -> within platform limits (doable)
- re-packing stuff in CMP using LZ77 algorithm (doable)
- re-generating a VEW file (http://www.wipeoutzone.com/forum/showthread.php?9959-Reverse-engineering-of-Wipeout&p=243437#post243437) (very difficult if not impossible as we do not know everything about it)

Do you still have the ATI edition ? It could be helpful since it is the only WO1 built for Windows -> if by chance they forgot stripping debugging information as they did for the MAC version of WOXL, we could learn a bit more with IDA. Going to PM you about it :D

30th September 2015, 08:06 PM
Just did a simple test which ended up pretty interesting, on the DOS demo you can entirely delete the WIPEOUT folder and the demo will still run and load the track -> there is definitely lot more happening in the EXE than sole game logic. i.e. couple of track data is within the EXE.

Try running it once, deleting/moving the folder and rebooting the PC, then run it again. There's probably track data still present in memory. If it still works after you rebooted, then it's the EXE file that's doing the work.

1st October 2015, 07:42 PM
Right, I'll give it a try !

15th October 2015, 03:00 AM
I could have sworn that I managed to get the cheat from the PSX version to work on the DOS version back in the day by translating the PSX inputs to whatever they corresponded to on the keyboard. It's probably easier said than done because I have a feeling either square or circle had no in game function (It's been a while) but I'm sure I did it because I remember finding it strange that I could find no mention of it online at the time.

15th October 2015, 07:55 AM
That X'APDGHOST code online is a scam, it does not work. Besides putting a savegame online with everything unlocked, I don't see any other solution. I did try to disassemble the game but haven't found any code, or maybe they were ciphered ...

Btw, just posted a tuto on how to run it properly with sound on newer machines (DosBox): http://www.wipeoutzone.com/forum/showthread.php?10058-Running-Wipeout-1-on-DosBox-(tutorial)


16th October 2015, 01:12 AM
I take it you can't just run the disc from DosBox then? Bit of a pain if so.

Still, I'll see if I can get mine fired up at some point soon and give it a go again. I'm sure I'm not making this up lol.

16th October 2015, 03:10 AM
You can but it's tedious, in the end you'll have to have a custom config to either disable GUS or set it up using ULTRASND folder. The advantage here is that you've got a profile specific to the game and you can even make a desktop shortcut. You can also setup D-Fend to be portable, you'd do it once and basically you'll always have your DOS games a mouse click away.

2nd May 2016, 07:23 PM
Okay, I finally got around to trying the cheats out on the DOS version. I can get the Firestar one to work but I haven't managed to suss out how to unlock Rapier class.

At the main menu press and hold the following:
Left Airbrake
Right Airbrake
Change View

(Please note that actual input depends on your control scheme, I'm not sure what the default controls are so you'll have to make do with the above.)

Like I said it's pretty much the same as the Playstation cheat with a few slight changes. The problem with the Rapier cheat is that involves pressing select and I can't seem to work out what that translates to, if anyone has an idea then please share.

Thanks for the set up guide in the other thread btw, was most useful.

Edit: Forget what I said about it possibly working on the Saturn version, I've just tried it and no joy.

3rd May 2016, 05:26 AM
In DOSBOX I've just tried holding down these keys in the order below at the spinning ag sys craft at the wipeout main menu.

1 Left Airbrake (z)
2 Right Airbrake (x)
3 Right arrow key
4 Fire (space)
5 Change View (tab)
6 Enter

The firestar cheat doesn't work for me. What am I not doing ?

Are there any visual or sound cues at the main menu once the key combo has been entered to say that the cheat is enabled?


Kabuki :?

3rd May 2016, 12:54 PM
Hmmm it sounds like you're doing everything right to me. Interestingly I tried to do it with the default controls just now and can't get it to work but as soon as I rebind them it does, no wonder nobody figured this out lol. Just to clarify, yes you should be doing it whilst start game is highlighted and the AG systems craft is on screen. There are no unusual sound cues to confirm that it has worked although it will jump to the class selection screen upon pressing enter.

Try rebinding the controls to letters on the keyboard and see if that fixes it.

The bindings I was using were:
Up/Down/Left/Right: Arrow keys
Airbrakes: H, J
Accelerate: M
Fire: N
View: B
Pause: V

Which meant my inputs on the main menu were:
H, J, Right arrow, N, B, Enter

Hope this helps.

- - - Updated - - -

I've knocked up a quick video here although it's probably not much help tbh.


4th May 2016, 05:29 AM
Yes! It works! Fantastic!! :D Thanks heaps for the video too!:clap:g

One of my childhood dreams come true lol ;)

You're a legend!


4th May 2016, 12:01 PM
Glad to be of assistance. :D

Sorry it took so long by the way.